Lockpoint Legacy Version Compatibility

Page Contents


This page describes the system compatibility for older, legacy versions (1.6.10 and prior) of Cenote Lockpoint, compatible with Confluence 5.x and below. Please see the System Requirements page for compatibility information for current versions of Lockpoint.

Confluence Compatibility

If you are using Lockpoint 1.5.5 or below with the legacy Confluence Clustered solution, please also see the Confluence Clustered compatibility section below for important details.

Do you need to manually download a .JAR for an earlier version of Lockpoint? All prior versions of Lockpoint can be downloaded from the Lockpoint download archive on the Atlassian Marketplace.

Confluence
Version
Compatible Lockpoint
Versions
Confluence
Version
Compatible Lockpoint
Versions
6.0 1.6.10+ 5.0 1.4.0 - 1.6.0
5.10 1.6.8 - 1.6.12

4.3

1.3.1 - 1.5.4
5.9 1.6.5 - 1.6.12 4.2 1.3.0 - 1.5.4
5.8 1.6.1 - 1.6.12 4.1 1.2.3 - 1.5.3
5.7 1.6.0 - 1.6.10 4.0 1.2.0 - 1.4.6
5.6 1.5.5 - 1.6.9 3.5  1.0.0 - 1.4.5
5.5 1.5.3 - 1.6.8 3.4 1.0.0 - 1.3.4
5.4 1.5.0 - 1.6.7 3.3 1.0.0 - 1.3.0
5.3 1.4.6 - 1.6.4 3.2 1.0.0 - 1.3.0
5.2 1.4.5 - 1.6.4 3.1 1.0.0 - 1.3.0
5.1.5 1 1.4.5 - 1.6.4 older n/a
5.1 - 5.1.4 1.4.1 - 1.6.4

1 In Confluence 5.1.5, a Confluence bug (CONFSERVER-30346CONFSERVER-30556) severely impacts the functioning of the Atlassian Attachments macro, as well as the ability to comment or use Lockpoint operations on any page containing that macro. For Lockpoint to work correctly with 5.1.5, you must update the Atlassian Attachments plugin as described in the "Workaround solution" section of CONF-30346.

Note: a security notice applies to all versions of Lockpoint prior to 1.4.3. We strongly recommend upgrading to 1.4.3 or newer if possible. Please see Lockpoint Security Notice 20130403 for more details.


Confluence Clustered

Cenote Lockpoint 1.1.0 - 1.5.5 supports the legacy Confluence Clustered system for compatible versions of Confluence. Lockpoint 1.6.0 and above do not support the legacy Confluence Clustered.

For the newer Confluence Data Center, see the  System Requirements for current versions of Lockpoint.

Java Compatibility

Java Version

Compatible Lockpoint
Versions

Java SE 8 1.6.0+
Java SE 7 1.3.4 - 1.6.12
Java SE 6 1.0.0 - 1.5.5
J2SE 5.0 1.0.0 - 1.3.0

Application Server Compatibility


Application Server
Version

Compatible Lockpoint
Versions

Apache Tomcat 8.0 1.6.1+
Apache Tomcat 7.0 1.5.0+
Apache Tomcat 6.0 1.0.0 - 1.6.0

Web Browser Compatibility

This table describes the web browser compatibility matrix for legacy versions of Lockpoint (1.0 through 1.6.0). For current versions of Lockpoint, see the System Requirements page.

OS Browser Browser Version Special Requirements Unsupported Features
 Windows Internet Explorer 11+

Requires Confluence 5.4.3 or higher. Earlier versions of Confluence do not support IE11.

1

Internet Explorer 10 -

Internet Explorer 8 - 9 IE8/9 are EOL. Lockpoint 1.6.12 is the last version of Lockpoint that supports these versions of IE. 1

Firefox 3.6+ -
Inline MS Visio/Project locking

Edge All - -

Chrome All

For Confluence 6.10+, all versions of Chrome are supported with Edit in App.

For Confluence 5.9-6.9, Chrome 50+, and Office 2010 SP2 or higher is required to use Edit in Office.

Inline MS Visio & MS Project locking require Confluence 6.11+ and Lockpoint 1.7+.
macOS Safari 5.0+ -


Firefox 3.6+ -


Chrome All For Confluence 6.10+, all versions of Chrome are supported with Edit in App.


WebDAV Client Compatibility

Cenote Lockpoint includes WebDAV file locking support, and Lockpoint is compatible with most WebDAV clients. 

If you experience problems with a particular WebDAV client, please contact Cenote Support so we can help resolve the issue.

The following Microsoft Office applications have been explicitly tested with Cenote Lockpoint.

OS Application Compatible Lockpoint
Versions
Windows MS PowerPoint 2013 1.5.5+

MS Excel 2013 1.5.5+

MS Word 2013 1.5.5+

MS PowerPoint 2010 1.0.0+

MS Excel 2010 1.0.0+

MS Word 2010 1.0.0+

MS Visio 2003 1.1.0+

MS Project 2003 1.1.0+

MS Excel 2003 1.0.0+

MS Word 2003 1.0.0+
MacOS MS Excel:mac 2008 1 1.0.0+

MS Word:mac 2008 1.0.0+

1 Lockpoint itself functions properly with Excel:mac 2008, although underlying issues with the Office Connector can cause Excel to be unable to re-save existing files to Confluence through WebDAV. This problem exists even without Lockpoint installed, so we recommend using caution with Excel:mac 2008 in a Confluence environment.